User Tools

Site Tools


Index

Translations of this page:


Appendices:

Download PDF

Layers

Layers are the key to mixing clips with each other. Each layer can play one clip at a time.

A composition can have any number of layers (although note that more layers will mean the computer has to do more work to composite them together).

New layers can be added with the Layer > New and Layer > Insert menu options. The New option adds the new layer to the top of the layer stack while the Insert option adds the new layer below the currently selected layer.

To select a layer, click the area that displays the layer's name (e.g. Layer 1). The currently selected layer is highlighted in blue.

The properties and effects for the currently selected layer will be shown in the layer tab at the bottom of the screen. The layer will also be shown in the preview monitor if it is active.

The layer can be cleared by clicking the X button at the far left of the layer strip. This will stop any clip that is playing on it.

The layer can be temporarily hidden by clicking the B (Bypass) button.

The layer can be displayed on its own by clicking the S (Solo) button.

You can rearrange the layers by using the two buttons with upwards and downwards pointing triangles on them.


Mixing and Compositing

Mixing audio being played by layers is very simple. Just use the A (Audio) slider to control the volume of each layer.

Mixing video can also be simple - use the V (Video) slider to fade layers in and out.

However, there are some fun things you can do with video. Firstly, there are many ways that video can be combined and many of these methods will give different results depending on what order the layers are in when they are mixed.

When Resolume composites layers, it starts from the one at the bottom of the stack, compositing it over a black frame. It then moves up the stack, compositing each layer in turn based on the blend mode selected and the opacity of the layer.

Blend modes are the methods that are used to do the compositing. Several are included with Resolume and more can be added as plugins. They are selected from the lists just to the left of the Opacity and Volume sliders.

Each layer can have three blend modes visible for easy access, so you can quickly pick between your three favorite blend modes, without having to scroll through the entire list. The currently selected one is highlighted in blue.

Tip! One quick way of mixing videos that gives a good result is to put a black and white clip in the top layer, and a colorful one below. Then set the blend mode of the top clip to '50 Mask'. The colorful clip will now only show in the white parts of the video on top, giving a new result with every clip you try it with.

Most blend modes mix the layers together, but some are actually transitions. For instance the Cube blend mode, will rotate put each layer on the side of the cube and rotate them in and out.

For more info on what some of the blend modes do, check the list below.

In all of the following descriptions, “layer” means the layer that the mode is applied to and “input” means the combined video of all of the lower layers that the layer is being mixed with.

50 Mask - This blend mode will mask the output based on the brightness of the layer. Whatever is black in the layer, will become transparent in the output. Whatever is white in the layer, will remain visible in the output.

50 Add and 50 LightenThese modes are very useful when AV clips are being mixed. The audio and video faders can be used together and make sense: When they are faded right up, you hear the audio from all layers and see the combined video from all layers.

Add - Mix the video so that at 50%, the layer is added to the input. At 0%, only the input is shown; at 100% only the output is shown.

Alpha - A simple crossfade effect. It is usually better to use Add or Lighten instead, as this mode tends to lead to dull looking output when layers are mixed. However, when your content has an alpha channel, this mode is the bees knees.

Luma Key - The opacity slider is used as a threshold. Pixels in the layer that are darker than the threshold are not shown. Pixels that are brighter are shown at full opacity.

Screen - A nice crossfade effect that usually gives a bright output when the layer and input are combined.

Shift RGB - A transition effect that pulls apart the Red, Green and Blue channel of the output, and then pulls in those channels of the layer.

Fade to White - Transitions from output to full white to layer. Useful to bring in a new layer with a flash!

These are just a few examples, it's best to try out each blend mode yourself and see what they do. Also experiment with different types of content, because some blend modes work better with certain types of content than others. For instance Burn and Lighten work well with video content, while Add and Luma Key can work great with more abstract clips.

Set your three favorites and off you go!


Layer Transport Controls

These allow you quick access to your currently playing clips. You can quickly change the playback speed or BPM setting of the clip, as well as change the playback direction and play mode. Also you have access to the playhead of the clip. 

This is a familiar way of working for Resolume 2 users. The great advantage is that you have a good overview over what your clips are doing, and you can change it instantly, without needing to select the clip first.

Tip! Move your mouse over the playhead of one of the clips in the layer transport controls, and wiggle your scrollwheel. Look mum, I'm scratching!

The layer transport controls can be found by choosing View → Show Layer Transport Controls, and they will pop up to the right of the layer preview thumbnails.


Auto Layer Transitions

These allow you to automatically add a transition when you trigger a new clip in a layer. This way you can smoothly blend from the old playing clip to the new one. Simply choose how long you want the fade to be with the vertical slider (between 0 and 10 seconds), and choose any of the transition modes from the drop down.

For a description of the available transitions, check the list of blend modes above. All the blend modes are also available as transitions, aside from 50 Add, 50 Lighten and 50 Mask. If you really can't decide on a favourite transition, there is also a random option, giving you a different transition every time you trigger a new clip.

The auto layer transitions can be found by choosing View → Show Clip Transition Controls, and they will pop up to the right of the layer preview thumbnails.


The Cross Fader

As well as using the layers' own volume and opacity sliders, we can also mix between layers by using the crossfader.

You can find the crossfader, below the layer strips, to the left of the deck selection buttons.

To use the crossfader, first select the layers that you want to use by clicking the A or B buttons below the volume and opacity sliders on the layers. You can set as many layers as you like to use the crossfader but the most common way to use it is to set one layer to A and another to B.

You will also need to set the opacity and volume sliders for the layers to the maximum values you want them to have while crossfading.

Now you can use the crossfader to control the volume and opacity of all of the layers that are assigned to the crossfader. When the crossfader is at A, layers assigned to A will be heard and seen. When the crossfader is at B, the B clips will be heard and seen.

This gives us a really easy way to control the opacity of multiple layers at the same time. Clicking on either A or B in the crossfader will automatically fade between the two layers over a period of 2 seconds.


Layer Properties

The properties for the currently selected layer are displayed in the Layer tab at the bottom of the screen.

You can use the textbox at the top of the tab to change the name of the layer.

The drop down menu to the right of the tab provides the same options as the Layer menu at the top of the screen.

Tip! Enable the Width and Height of all your layers, and set it to the composition width and height. That way you never have to worry about your footage not filling the screen again!

Dashboard - This is used to quickly access parameters you use a lot. Please see the dashboard chapter for more info.

Auto Pilot - Here you can control the sequencing for the entire layer. Check out the Auto Pilot chapter for more details.

Audio Effects - If you have applied any audio effects, they show up here.

Volume - Control the volume of any clip that plays in the layer. This works in combination with the master composition volume and individual clip volumes.

Pan - Send the audio from the clip playing in this layer to the left or the right

Mask - If you created a mask, it will show up here. You can use the B and X buttons to respectively bypass and eject it. Use the I button to invert it.

Video Effects - If you have applied any video effects, they will show up here.

Blend Mode - Change the current blend mode for the layer here as well as on the layer strip (see Mixing and Compositing above for details)

Opacity - Set the opacity for the layer here as well as on the layer strip.

Scale - Scale the surface that the layer is drawn on in the output.

Width, Height - If enabled, any content in this layer will be scaled to this width and height in pixels.

Position X, Position Y - Tweak the exact position of the layer, pixel by pixel

Rotate X, Rotate y, Rotate Z - Rotate the surface that the layer is drawn on

Anchor X, Anchor Y, Anchor Z - Change the position of the surface that the layer is drawn on and also the point that the surface is rotated around if you use any of the Rotate parameters.


The Adobe Flash Plugin is needed to display this content.

The Adobe Flash Plugin is needed to display this content.

Page Tools