Massive FPS drop on Blackmagic Live Input.

Post your questions here and we'll all try to help.
stv_myr
Met Resolume in a bar the other day
Posts: 7
Joined: Mon Nov 23, 2015 22:00

Massive FPS drop on Blackmagic Live Input.

Post by stv_myr » Sat Nov 28, 2015 20:50

Hi,

i have a Massive drop from 150 to 6FPS if i select an Live input from an Blackmagic Decklink miniRecorder.
Does anyone know this problem? i don't have this problem with Arena 4 and OS X 10.10


My Rig:

Apple Mac Pro
OS X 10.11.1
2x2,26GHz Xeon
16GB ECC RAM
512GB 840Pro SSD
1x Nvidia Quadro 4000 2048MB
1x Nvidia GT120 512MB

Arena 5.0.1
Composition Size: 2920x1280
Decklink Input Resolution: 1080p30

Rossnz
Met Resolume in a bar the other day
Posts: 6
Joined: Fri Apr 11, 2014 00:34

Re: Massive FPS drop on Blackmagic Live Input.

Post by Rossnz » Tue Mar 22, 2016 02:41

Did you find a solution?
We have a similar problem although not as extreme

dcaiman
Met Resolume in a bar the other day
Posts: 12
Joined: Mon Sep 21, 2015 17:53

Re: Massive FPS drop on Blackmagic Live Input.

Post by dcaiman » Wed Mar 23, 2016 10:26

Similar problem. No solution.
Only solution, change Nvidia card model.

This is my post with this problem: Problems with GTX970. Low frame rate.
In a project with 1920 x 1080 resolume 4.2.1 in a osx 10.10.4 shows an output frame rate of 60 fps.
All internal content is DXV3 1080 format.

When active a video signal from a Blackmagic live, the low output frame rate to 19 fps.

We tested several blackmagic with the same result (19fps).
- Studio DeckLink 4K - DeckLink SDI 4K - UltraStudio SDI - Intensity Shuttle for USB 3.0 -

This problem occurs in two different computers.
Mac Pro 5.1 with 16GB RAM and i7 Hackintosh with 4790 K with 16Gb RAM.

If we use two computers in 770 or 680 Nvidia cards and blackmagic live video activated, the output frame rate remains at 60 fps. (nvidia drivers not installed)

Using the Nvidia 770 or 680 cards with Nvidia driver drops the frame rate to 19fps.

Is it a compatibility problem resolume with Nvidia drivers?

mosu
Is taking Resolume on a second date
Posts: 25
Joined: Mon Dec 10, 2012 06:35

Re: Massive FPS drop on Blackmagic Live Input.

Post by mosu » Mon Apr 25, 2016 06:20

dcaiman wrote:Similar problem. No solution.
Only solution, change Nvidia card model.

This is my post with this problem: Problems with GTX970. Low frame rate.
Is it problem really no solution???
I got the same problem on AMD card
spec:
MBPR15" with AMD R9 M370X(late 2015 model) / Arena 5 / 1 1080p output / 1 1080p dxv3 clip and 1 BMD input are triggered

FPS drop from 60 to 30 since BMD input were triggered.
and FPS even drop to 15 when I attach another 1080p output

I have 4 different MBPR 15" models, 2 are NV card, 2 are AMD card,
they all have obvious FPS drop.
they are all laptop level GPU, but all of them can handle 4 dxv3 1080p clips at the same time without huge FPS drop

SO,
what kind of hardware setup(specs) can provide a stable & smooth result if I need
2 1080p with advance output
2 layers with 1080p dxv3 clip
1 layer with LIVE input

I think this setup is very easy and essential

Joris
Doesn't Know Jack about VJ'ing or Software Development and Mostly Just Gets Coffee for Everyone
Posts: 5180
Joined: Fri May 22, 2009 11:38

Re: Massive FPS drop on Blackmagic Live Input.

Post by Joris » Mon Apr 25, 2016 08:45

Thanks for reporting the issue, guys.

We'll take a look and see if we can recreate it.

miek
Met Resolume in a bar the other day
Posts: 8
Joined: Fri Jan 06, 2017 21:24

Re: Massive FPS drop on Blackmagic Live Input.

Post by miek » Fri Jan 06, 2017 21:45

I think I've found temporary solution for this issue.

I've tested wirecast's virtual camera out with full HD resolution as a source in resolume (Capturing 1080i50 in wirecast and sending it to virtual camera out). Works on 60fps without any fps drop. I didn't tested latency.
So I think that something wrong with Blackmagic's support in Resolume. It works OK on low resolutions but uses to much CPU on Full HD.

By the way, output to Blackmagic do not works properly too...

Z87PRO motherboard
Nvidia 960GTX
i5 + 8GB ram, SSD
Hackintosh 10.11.6 El Capitan
Blackmagic Intensity Pro 4K
Blackmagic Decklink Duo SDI

Resolume Arena 5.0.0
Wirecast 6.0.5

User avatar
cvanhoose
Is seriously in love with Resolume. Met the parents and everything
Posts: 276
Joined: Tue Aug 21, 2012 22:18

Re: Massive FPS drop on Blackmagic Live Input.

Post by cvanhoose » Fri Jan 06, 2017 22:29

miek wrote:I think I've found temporary solution for this issue.

I've tested wirecast's virtual camera out with full HD resolution as a source in resolume (Capturing 1080i50 in wirecast and sending it to virtual camera out). Works on 60fps without any fps drop. I didn't tested latency.
So I think that something wrong with Blackmagic's support in Resolume. It works OK on low resolutions but uses to much CPU on Full HD.

By the way, output to Blackmagic do not works properly too...

Z87PRO motherboard
Nvidia 960GTX
i5 + 8GB ram, SSD
Hackintosh 10.11.6 El Capitan
Blackmagic Intensity Pro 4K
Blackmagic Decklink Duo SDI

Resolume Arena 5.0.0
Wirecast 6.0.5
First try updating Arena to the latest release. I can not recreate this issue with any of my machines. MBP AMD + Nvidia. PC AMD + Nvidia
1080i @60
BM thunderbolt express - sdi and hdmi
BM PCIe decklink

miek
Met Resolume in a bar the other day
Posts: 8
Joined: Fri Jan 06, 2017 21:24

Re: Massive FPS drop on Blackmagic Live Input.

Post by miek » Fri Jan 06, 2017 23:35

Thank you for your reply

I tried Resolume 5.1.2 with no luck. Maybe I have the problem with hackintosh or motherboard's kexts. Everything worked in windows7.

M

fraktal
Met Resolume in a bar the other day
Posts: 2
Joined: Sat Jan 07, 2017 17:27

Re: Massive FPS drop on Blackmagic Live Input.

Post by fraktal » Sat Jan 07, 2017 19:09

Hi All,

We have the same problem. Our idea is, maybe this is az El Capitan problem. We have 2 servers, one is El Capitan, the other one is Yosemite. The Yosemite is working fine, the El Capitan has the problem.
What do you think?

Good configuration:
Titan GTX
10.10.3

Bad configuration:
GTX 980Ti
10.11.6.

miek
Met Resolume in a bar the other day
Posts: 8
Joined: Fri Jan 06, 2017 21:24

Re: Massive FPS drop on Blackmagic Live Input.

Post by miek » Sat Jan 07, 2017 19:56

Dear Fraktal,

Is there Nvidia's alternative driver on your Yosemite machine or standard?

M

Post Reply