Page 1 of 1

Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Wed Jul 11, 2018 16:31
by manoeuvretv
When using faders (midi) opacity slider visual feedback stops when an envelope hits 100%, that doesn't seem right?
Opacity_04.PNG
Opacity_04.PNG (21.65 KiB) Viewed 2052 times
Opacity_03.PNG
Opacity_03.PNG (22.31 KiB) Viewed 2052 times

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Wed Jul 11, 2018 21:59
by Zoltán
That's how it should work.
The X axis of the envelope is the param control input/timeline, the Y axis is the output value / param value.
You can see the selected keyframe's opacity value is 100% in both screenshots.

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 03:22
by manoeuvretv
Hi can you please look at this video that shows the problem in more detail. The problem is with the display of the interface's opacity sliders, it's not how Resolume worked in previous versions.

https://www.dropbox.com/s/smy9tvp4aza7b ... M.mp4?dl=0

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 03:28
by manoeuvretv
phpBB [video]

https://www.youtube.com/watch?v=pbUXggoaaCY

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 08:37
by Zoltán
Could you send us your composition and midi mapping preset you use with it?
Thanks!

Do you have the layer opacities mapped to the same midi control?

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 08:56
by manoeuvretv
You don't need midi to see the problem. Just add a point to layer opacity at X=50% Y=100%. When you move the opacity slider on the layer panel to 100% the one on the interface will only go to 50%.
Here is an example file with midi mappings on layer 1.

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 11:08
by Zoltán
Thank you!
Looks like the layer fader is not updated when the param value doesn't change any more (at 100%)
When I move the middle keyframe from 100% to 99% then the fader updates all the way.
I'll create a ticket.
Turns out we already have a ticket for this #8792.

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 14:29
by manoeuvretv
Thanks, will we be seeing a point release any time soon with a fix?

Re: Layer Opacity, Midi, Envelopes, weird feedback.

Posted: Thu Jul 12, 2018 14:56
by Zoltán
manoeuvretv wrote:
Thu Jul 12, 2018 14:29
Thanks, will we be seeing a point release any time soon with a fix?
I can't give you an estimate on that.

As a workaround, try to set one of the 2 same value keyframes to a slightly different value, like from 100% to 99%.