Page 1 of 1

Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Mon Jul 08, 2019 16:05
by Ladin
Hi, Now testing new version of Resolume, comparing with 6.1.3. On the same machine.

Setting up the same composition size, settings, in both versions, using the same testing file. In 6.1.3 there is no problem to play the DXV3-HQ 50fps footage perfectly in 50fps. In version 7 it drops to 32 and jumping to 48 fps wich causes video choppy and it is useless.. With virtual output enabled only.

PS: Previewing that file causes it aswell..

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Mon Jul 08, 2019 22:19
by bart
Can you please send us the log file using the feedback form in the preferences so we can have a look please?

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Tue Jul 09, 2019 15:10
by Ladin
A few logs sent.. Problem solved now. Powerscheme in windows settings and underclocked processor. My childisch mistake.. Strange thing is, that in balanced powerscheme in version 6.1.3 fps is oscillating from 48 to 50 fps and newer drops under 47 fps, but in version 7 it´s constantly dropping under 36 fps (sometimes under 25) and exceeds a 45 fps border just sometimes..
So in 6.1.3 average fps - around 49 (little bit more) and in version 7 avg fps about 40..
With the same usage of a system..

But yeah. Maximum performance powerscheme is the only way..

Edit: 6.1.3 is using 6-7% of CPU and about 11% GPU..
7.0.0 is using 6-7% of CPU and about 17% GPU..

But 6.1.3 automaticaly clock the CPU to higher rates of GHz..

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Tue Jul 09, 2019 15:38
by Zoltán
It's probably the DMA textures mode causing the difference. It's enabled by default in Resolume 7 (Video preferences.)
It helps making the texture uploads to the GPU faster, by using DMA instead of CPU, so the CPU is not used as much. In turn looks like it can throttle it's frequency, because of the smaller load.

Could you check the DMA textures settings in Version 6 and 7?
And check if 7 with DMA off behaves the same with the power saving scheme as Resolume 6 on your machine?

Thanks!

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Tue Jul 09, 2019 16:08
by Ladin
Both were on Autodetect. Forcing them off 6.1.3 boost the CPU clock a little bit higher (up to 2.3GHz - avg. 1.9GHz) and GPU falls to 10 % finally locking on 50fps (yeah, sometimes drops to 49.8).
The 7.0.0 the cpu boost is the same like with Autodetect (up to 1.7GHz avg. 1.5GHz) the GPU is the same 15%-17% and the FPS are same like before.. So oscillating between 30fps and 48fps..
Strange..

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Tue Jul 09, 2019 16:41
by Ladin
So.. I made a torture test. Powerscheme on maximal performance..
Exported file 19200x1080. Composition size 19200x1080. 50fps, 8bit colours, monitor 50Hz.. DMA force off.. Virtual output 19200x1080..
Same file in three layers. Max opacity.
AND

6.1.3 - 47fps +-1fps (during second test - restarting Reso 47fps)
7.0.0 - 26fps +-1fps (during second test - restarting Reso 29fps)

So, it has nothing to do with powerscheme or DMA..

PS: Logs sent..

Re: Performance drop 6.1.3 vs 7 Optimalisation (again:) )..

Posted: Thu Jul 18, 2019 00:01
by Zoltán
Are the 3d settings in the Nvidia control panel the same for both 6 and 7 now?