Deck switching drops OSC message??

Post your questions here and we'll all try to help.
Post Reply
vectorfuton
Is taking Resolume on a second date
Posts: 35
Joined: Mon Aug 10, 2020 23:52

Deck switching drops OSC message??

Post by vectorfuton »

So I'm sending OSC messages from Ableton to Resolume, and I have one Live track / clip dedicated to switching between decks which sends out 'on' messages (OSC values which trigger the Deck switch) and another track / clip which I use to trigger the Column parameter.

Basically, I have it set so that I can launch clips in Live that will switch between Resolume Decks, and at the same time I am sending a parallel clip / OSC message that triggers column 1.

What I am finding is that, in a Deck with somewhat less video cells / load time, when I launch the clips in Live it performs as I want it to. The Deck is changed, and once fully loaded, it then retriggers column 1 so that I'm not still playing video from Decks I was just in. But if there are more vid clips / longer load to switch the Deck over, the same clips / OSC messages I'm sending from Live seem to 'drop' the Column OSC message. The OSC message changes the Decks no problem, but the second is inconsistent with the Column parameter.

Curious, is there a way to get around this issue? I am going to strip down my Decks so that they load as quickly as possible and it still allows time for the Column message to get through, but is this even a thing? Should not the OSC just be processed in the order it was received, even if it takes a little while to load? Seems to me if it works in one instance, then it's not like I'm prematurely launching Column *before* the Deck switch, so not sure what I could be missing.

Alternatively, if there is an easier / more efficient way to basically, in as few moves as possible, change to another Deck and launch the first column on that Deck upon load, would love to hear it. Cheers.

(I would house the footage all in one Deck if I could, but I have OSC addressed specifically to Column 1 so as to work with the workflow I have in Ableton, and have been unable to come up with a way around this, can go into more detail if need be)

Zoltán
Team Resolume
Posts: 5074
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: Deck switching drops OSC message??

Post by Zoltán »

If you send the messages in a single bundle, their order is not guaranteed.
There is a lot happening when you switch a deck, first, the old deck has to be cleaned up, then then new deck clips have to be added, and then loaded.
There is a lot of time in these where there are no clips in column1 actually.

I'd send the deck switch first, then listen for reply messages about the deck switch state, then send the Column trigger after that.

(UDP protocol means that no messages are guaranteed to arrive btw. but if you have a good network, that should be no problem)

Do you see the messages come in properly in the OSC inspector in the Resolume preferences?

Layers have an option to trigger first clip on load, but that only works on composition load.
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

Post Reply