Awful frame rates on OSX

Post your questions here and we'll all try to help.
Post Reply
borez
Met Resolume in a bar the other day
Posts: 8
Joined: Thu Jul 04, 2019 23:58

Awful frame rates on OSX

Post by borez » Sun Jul 14, 2019 12:47

OK, so I'm running a 2018 i7 6 core Macbook pro ( Radeon Pro 560X ) OSX Mojave with 16g ram playing all DVX clips from an EVO SSD and the video is stuttery as hell with only one video playing in just the internal video monitor and no external video connection.

In the preview window I'm hitting 20fps tops. No effects running.

I can run 4 or 5 videos no problem but the frame rate stays around 20fps and it's all stuttery, the CPU is showing 10%.

Frame rate is set to auto, changing it to another rate does nothing.

Also this is on a fresh user account running nothing else but Avenue 7.

Video playback is fine when playing the files outside of Avenue too.

Anyone have any ideas, I'm pulling my hair out?

borez
Met Resolume in a bar the other day
Posts: 8
Joined: Thu Jul 04, 2019 23:58

Re: Awful frame rates on OSX

Post by borez » Sun Jul 14, 2019 19:02

Solved this somewhat, I had a radial blur effect running that was killing my frame rate, removed it and I get a steady 60fps or 30 fps when plugged into an external HDMI source. More importantly though it's a steady 30fps and not a stuttery mess.

Zoltán
Team Resolume
Posts: 3818
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: Awful frame rates on OSX

Post by Zoltán » Thu Jul 18, 2019 00:05

Blurs can get very heavy easily, turning up the quality indeed.
Could you attach a screenshot of your Composition settings? (Composition menu - Settings)
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

borez
Met Resolume in a bar the other day
Posts: 8
Joined: Thu Jul 04, 2019 23:58

Re: Awful frame rates on OSX

Post by borez » Thu Jul 25, 2019 22:55

Sorry about the delay, I've been away touring.
Screen Shot 2019-07-25 at 22.53.29.png

Zoltán
Team Resolume
Posts: 3818
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: Awful frame rates on OSX

Post by Zoltán » Fri Jul 26, 2019 11:38

Thanks,
Resolume caps the frame rate at the slowest display you output to.
Is your display running at 30Hz?
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

Post Reply