Crossfader Mix-Mode "Bug"

Post your questions here and we'll all try to help.
Post Reply
Is seriously in love with Resolume. Met the parents and everything
Posts: 465
Joined: Thu Oct 02, 2008 09:30

Crossfader Mix-Mode "Bug"

Post by HerrNieDa »

if i select 1 and 2 (lets say Layer 2 is 50% Darken) to "A", the mixing isn't done right. If i move the crossfader now from the middle to "A", the result is correct, if i move him back the output is wrong (at least to my eyes... i think maybe its the alpha-blend from crossfader!?). also if i add Layer 3 to "B", Layer 2 is only mixed correctly if the crossfader is at "A"-Position.

maybe the problem is also that "A" and "B" are just groups and are not seperatly rendered

at least an option to enable the different mix-modes on the crossfader would be a really nice function.

i never really used the crossfader cause of this and i wonder if it's a Bug or if it's just too complicated to implement it in R4?
MainSys: Z77 UP5,3570K,32GB Ram,GTX 285, M3 128GB,4x3TB R5@LSI9750
VJSys 1: 990FX UD5,X6 1045T,16GB Ram,GTX970+610+610,M3 128GB,3x1TB R0
MBP 3.1; Schenker A102 (650m) & P702 (675m)

User avatar
Resolume honorary member
Posts: 2837
Joined: Tue May 08, 2012 15:19
Location: Oakland, CA

Re: Crossfader Mix-Mode "Bug"

Post by Oaktown »

If you use the A-B cross faders, your blend modes will be at the set opacity when you're at either A or B. When you're in the middle, the blend mode's opacity will be at 50% of its setting.

So for instance if you set Layer 2 - Darken at 50% to A, it'll be at 100% of its setting at A (so 50%), 0% at B (so 0%) and 50% in the middle (so 25%) since it's a linear fade.

Try this:
  • L1 to Add at 100%
    L2 to Darken at 50%
    L3 to Darken at 50%
    Take a snapshot
now set to:
  • L1 to Add at 100%
    L2 to Darken at 100% to A
    L3 to Darken at 100% to B
    Have your A/B cursor in the middle
    Take a snapshot
If your two snapshots are identical then it's working as it's supposed to.

Post Reply