Smooth playback - new topic

Post your questions here and we'll all try to help.
User avatar
cosmowe
Knows Resolume better than the devs
Posts: 1304
Joined: Fri Mar 25, 2011 10:27
Location: cologne // germany

Re: Smooth playback - new topic

Post by cosmowe »

@pupdogg:
I'm sorry, but I'm shure that this kind of jittering has nothing to do with this kind of anti-smoothness talken in this topic.

In your video it looks like that you slowed the clip down or you've made a BMP configuration for that clip...playbacked it so slow that all smoothness of the original clip was gone. ....or.... you've made a BMP configuration for it... and choosed the wrong audiobuffer for your system. possibilitys....possibilitys ....possibilitys :roll:


Greetz
cosmowe
w10 || Schenker U506 || lemur || kp3 || pulse || leap motion || magewell capture dongle

User avatar
cosmowe
Knows Resolume better than the devs
Posts: 1304
Joined: Fri Mar 25, 2011 10:27
Location: cologne // germany

Re: Smooth playback - new topic

Post by cosmowe »

Image

Hello everyone....again,
here are some screencaptures I've made so anybody in this topic sees what we are talking
about.

////
IMPORTANT
To see the "real" stutters in the screencaptures you have to set your display
refresh rate to 60Hz for the 60&30fps clips and to 50Hz for the 50&25fps clips

////

Download the clips and rename them right...for example "60fps_cap.mov". I'm sorry for that
but vimeo does not allow me to pre-name the downloads. Yes, it is possible to watch the clips
on vimeo directly but vimeo convert the videos from 60fps to 30fps..and the 50fps to 25...
so the visible result will be not exactly right. Who really knows how they convert stuff... :roll:

Please look the whole clip from beginning to the end. Otherwise you'll miss how the clip
playback jumps between phases of 100% smoothness and stuttering.



You can download the files via the Vimeo download button.

DOWNLOAD - 60fps

DOWNLOAD - 30fps


DOWNLOAD - 50fps

DOWNLOAD - 25fps



I filmed the 60&30fps clips with 1280x720 @ 60fps on a display which was set to 60Hz and
the 50&25fps clips with 1280x720 @ 50fps on a display which was set to 50Hz.

Please check if your display is fully compatible to 50Hz. For example the
Samsung Syncmaster series are supporting 50 Hz input...but internally convert it back
to 60 Hz to be able to show you something :roll: Just for your information.

Greetz
cosmowe

Image
Last edited by cosmowe on Tue Feb 03, 2015 13:33, edited 4 times in total.
w10 || Schenker U506 || lemur || kp3 || pulse || leap motion || magewell capture dongle

philmcrackin
Hasn't felt like this about software in a long time
Posts: 65
Joined: Wed Mar 07, 2012 14:48

Re: Smooth playback - new topic

Post by philmcrackin »

I just realized I encoded a bunch of clips in 29.97 FPS, i'm outputting at 60hz into a projector running at 60hz. Is there going to be a big difference if re-encoded them to 30 FPS?

@pupdogg: Maybe you should just make generative visuals in Resolume and get a capture card to run a camera into it, (Use a Blackmagic Intensity Pro, Matrox MX02 has too much latency in my experience) that would be a lot more unique and interesting than just playing video-clips. What's the point of dropping so much money on a computer just to use Resolume to play pre-rendered video clips when it's capable of so much more than that?

dbassix
Hasn't felt like this about software in a long time
Posts: 71
Joined: Sat Sep 25, 2010 22:47

Re: Smooth playback - new topic

Post by dbassix »

Any updates / news regarding smooth playback? Tried PlaybackPro and Qlab both playing smooth, same video in resolume stuttering, even in DXV.

Any statement from the resolume team would be nice.

Joris
Doesn't Know Jack about VJ'ing or Software Development and Mostly Just Gets Coffee for Everyone
Posts: 5185
Joined: Fri May 22, 2009 11:38

Re: Smooth playback - new topic

Post by Joris »

Our statement remains the same as before:

We're aware of issues with perceptively smooth playback, particularly visible on slow moving, high contrast video. As explained at length before (and clearly visible in the examples from Cosmowe above), this is caused by discrepancies in Resolume's playback of the video frames and the output's refresh rate.

We are very aware of the demand for smoother playback, especially on theater or corporate productions. We have a few ideas on how to improve this, but on the short term we cannot commit to any improvements in this area.

asperi
Hasn't felt like this about software in a long time
Posts: 103
Joined: Mon Nov 07, 2011 01:03

Re: Smooth playback - new topic

Post by asperi »

Just some notes.. I have found these pointers to be true for the most part.
1- Have your clips the same resolution as your session. And have all of the clips the same codec and resolution.
2- If you are running at 60hz, 60 fps can help or 30fps, 29.97 seems to not be as smooth.
3- Of course make sure everything is up to date.

Just throwing that out there. I do wish there was some sort of guide or fix to maintain smooth playback..

Warspite
Hasn't felt like this about software in a long time
Posts: 145
Joined: Thu Nov 01, 2012 14:36

Re: Smooth playback - new topic

Post by Warspite »

It is not Resolume fault. I have absolutely same problem with same videofiles in mediaplayers with enabled dxva. Somehow it is how current GPUs are working. To fight this i found only one weapon - performance: i try to get stable 55-60fps.

davide93
Is taking Resolume on a second date
Posts: 27
Joined: Fri Jan 25, 2013 19:00

Re: Smooth playback - new topic

Post by davide93 »

Hi there,
I've bought Resolume one year ago and right now I have never been able to use it once successfully for a performance for this issue. I've sent you some recording and someone at resolume confirmed me it was the
well known issue. The same person proposed me a refund and I refused it because I would really like to see this great application working because I find it extremely simple to use it. Please can you tell me if there is any news on this side? I've seen there is the version 4.1.6 available to download it.
Is there any improvement of this issue with that version?
Please let me know and keep us updated from time to time. For me, but I guess for all of us is very important to know any news about it.

Best,

Davide

stikmanlabs
Met Resolume in a bar the other day
Posts: 7
Joined: Sun Jul 14, 2013 16:23

Re: Smooth playback - new topic

Post by stikmanlabs »

noticing the same issues

it looks like every 3rd or 4th frame is dropping and occasionally appears to repeat frames

media is playing from fusion io iofx cards that is capable of keeping up with multiple 8k layers at 60 fps

other media software is giving ultra smooth playback

I am seeing glitchy playback even on standard hd files

doesnt matter if its 1080p or massive resolution ...just not as smooth as it should be

all content is rendered with dxv codec encapsulated into .mov files and the platform is windows

2 machines experiencing similiar issues one is win 8 64bit pro 32gig ram and win 7 64 bit pro 16 gig ram

this is almost to the point that we are going to abandon the resolume platform all together

davide93
Is taking Resolume on a second date
Posts: 27
Joined: Fri Jan 25, 2013 19:00

Re: Smooth playback - new topic

Post by davide93 »

Please can anybody @ Resolume answer to my questions?
I need Resolume to works perfectly by the end of november for 2 shows in Russia
do you think is something that can happen?
Last year in this period I asked the same for january 2013 and the answer was that it wouldn't have happened.
Well now it's one year later so the time to work on that and fix it was enough.
So please stop adding new feature and fixing other bugs which are important as well but this one is a deal breaker!!!

Please let me know.

Best,

Davide
davide93 wrote:Hi there,
I've bought Resolume one year ago and right now I have never been able to use it once successfully for a performance for this issue. I've sent you some recording and someone at resolume confirmed me it was the
well known issue. The same person proposed me a refund and I refused it because I would really like to see this great application working because I find it extremely simple to use it. Please can you tell me if there is any news on this side? I've seen there is the version 4.1.6 available to download it.
Is there any improvement of this issue with that version?
Please let me know and keep us updated from time to time. For me, but I guess for all of us is very important to know any news about it.

Best,

Davide

Post Reply