Triplehead2go Digital Edition only shows a RED light and no signal.

Bro, does your rig even lift?
Post Reply
Met Resolume in a bar the other day
Posts: 1
Joined: Tue Apr 02, 2019 17:30

Triplehead2go Digital Edition only shows a RED light and no signal.

Post by gabrielvasquesb »

Hello, I am new and forgive my english, I'm not a english native.

Could anyone please help me?
I bought a MATROX TRIPLEHEAD2GO DIGITAL EDITION from a friend of mine, which in case he lost the driver installation CD. And even by downloading the drivers from the Matrox website, I can not put the hardware to work. I tried using DVI-D to HDMI adapters, with DVI-I to VGA and did not work. I did all the steps in the manual and even then I did not get any signals. The only light that lights up is a red LED light, which in case when connecting the output cables the light is flashing red, I have already performed the compatibility test and my PC passed all the tests, on the Matrox website I downloaded the files:


but when I run I get an error message: No matrox hardware detected.

My pc is a Lenovo ideapad Y700.

I do not know what else to do, please help me, I have a big event that will be need this 3 screens on Sunday and I really need to be able to turn these projectors to work.

Team Resolume
Posts: 5028
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: Triplehead2go Digital Edition only shows a RED light and no signal.

Post by Zoltán »

I'd guess, it's the HDMI dongle you have there causing issues.
But sounds like a question Matrox support might be able to help you with better.
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free:
VJ footage:

Hasn't felt like this about software in a long time
Posts: 68
Joined: Thu Aug 02, 2012 14:27

Re: Triplehead2go Digital Edition only shows a RED light and no signal.

Post by Scratchpole »

Did you plug in a USB cable?
I don't see one in your photo's.
You need to plug in the USB to communicate with the Matrox and set the edid with the Matrox software.

Met Resolume in a bar the other day
Posts: 14
Joined: Mon Feb 11, 2019 18:45

Re: Triplehead2go Digital Edition only shows a RED light and no signal.

Post by djcyph »

So I just went through getting this to work with our projectors this week and there's some specific things you have to do to get it to work right. A solid RED LED means that you are outputting the wrong resolution but blinking is probably because hardware is not detected like you stated. The Triplehead is a little wonky and you have to do a few things to get the hardware to be recognized. You do have the correct firmware and Matrox software files. Before steps below, I would uninstall all Matrox software.

First, make sure your computer is off (important) and connect all video cables (I use DVI-VGA for output), including the USB. I was having no hardware detected as well at first and the reason was because our USB cable was too long. The triplehead was put in our ceiling back in the day by someone else so when connected to a really long usb you get signal loss and hardware not detected. When I took the triplehead out of the ceiling and closer to the computer, the firmware ("THDE_u140_v2_3_53_t6_72.exe") was then able to detect the device. After firmware update, it''ll probably have you restart. Next install the PowerDesk software, and then restart.

To confirm the hardware is updated/detected, open the PowerDesk quick setup, it should show your triplehead2go with three outputs. I wouldn't mess with anything in here unless it doesn't show all the 3 outputs, it could show up as just two or not seeing all your "monitors"...even if it does show just 2, for now, just open of the PowerDesk normal software and go to Multi-Display setup. Next is determining your resolution of each projector. We have 9 projectors, 3 per screen, and they are only SVGA which is 800x600 resolution per projector. Since we are outputting to 3 displays, the resolution for my setup would be 2400x600. In Multi-Display Setup, make sure you have the correct "Main Display" and "Output Settings" selected. Now in resolution, again for my setup, you should see 2400x3 (3x1). If you don't see (3x1) then it's not working right. If you do, you're good to go. Make sure your composition in Resolume is 2400x600 (or whatever your 3 projector resolution is).

If you don't see a (3x1) in Multi-Display, I would try opening up the Quick Setup again and see if it says not all your displays are connected. If it does, check "Override default settings" and select 3 monitors apply, restart computer and then open normal Multi-Display again and try steps above.

Now like I said at first, the Triplehead is a little wonky so if still not working, I would try setting the second display resolution in Windows or Mac to 2400x600 (or whatever your resolution is). Then I would completely shut down, boot back up and try the other steps above. Anytime cables come out, make sure everything connected right way before you turn computer on.

It's working great for me now, let me know if you have any questions.

For anyone wondering, we get 9 projectors because we piggyback projectors together with projector output. I know not best for quality, but for our needs it works great.

Post Reply