OSC clip playback

Post your questions here and we'll all try to help.
theoriz
Met Resolume in a bar the other day
Posts: 1
Joined: Tue May 22, 2018 08:50

OSC clip playback

Post by theoriz » Mon May 28, 2018 15:36

Hi,

I encountered two problems during a show I made using Resolume 6.0.7 and OSC.

First problem : let's say I want to control clip 1 on layer 3 : if I send "/composition/layers/3/clips/1/transport/position/behaviour/playdirection" and add an int argument between 0 and 3 (as written in documentation) I will only be able to play backward or forward with "0"and "1" values, "2" and "3" values won't have any effect (no pause or random playback).

The second one appeared when I tried to control the same clip timeline position through OSC. Wherever I move the position, the media restarts and then go to the asked position. This doesn't appear when the position is moved with a mouse. A trick I found is to set the media on pause manually (because it doesn't work with OSC as said above) and then move.

Are those bugs known ?

Thank you,

Alex
Last edited by theoriz on Mon May 28, 2018 15:48, edited 2 times in total.

User avatar
Zoltán
Team Resolume
Posts: 3399
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: OSC clip playback

Post by Zoltán » Mon May 28, 2018 15:46

Yes, we're working on it.
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

nuvedai
Met Resolume in a bar the other day
Posts: 4
Joined: Thu Mar 14, 2019 15:06

Re: OSC clip playback

Post by nuvedai » Thu Mar 14, 2019 16:55

I still have the same problem.
OSC play and pause (.../direction/2, .../direction/3) don't work, on global, layer and clip levels,
This problem exists both when trying to send OSC messages manually, but also when syncing two Resolume Arenas on two computers through OSC.

User avatar
Zoltán
Team Resolume
Posts: 3399
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: OSC clip playback

Post by Zoltán » Thu Mar 14, 2019 17:06

nuvedai wrote:
Thu Mar 14, 2019 16:55
OSC play and pause (.../direction/2, .../direction/3) don't work, on global, layer and clip levels,
These should be messages to the address:

/composition/layers/2/direction
with an integer argument: 0 to 3

/composition/layers/2/direction/2 address alone won't work.
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

nuvedai
Met Resolume in a bar the other day
Posts: 4
Joined: Thu Mar 14, 2019 15:06

Re: OSC clip playback

Post by nuvedai » Thu Mar 14, 2019 17:34

Zoltán wrote:
Thu Mar 14, 2019 17:06
These should be messages to the address:

/composition/layers/2/direction
with an integer argument: 0 to 3
I apologize, that's what I meant.
Sending integer / float 0, to an address like /composition/direction or /composition/layers/1/direction, works.
Sending any other number, int or float, always triggers the "play forward" button.
As if inside Resolume Arena the type is actually coded as a boolean (where anything other than 0 is interpreted as 1).

Like I said, this also causes a problem with Resolume's own OSC syncing feature, so it is definitely a bug on Resolume's side.

User avatar
Zoltán
Team Resolume
Posts: 3399
Joined: Thu Jan 09, 2014 13:08
Location: Székesfehérvár, Hungary

Re: OSC clip playback

Post by Zoltán » Thu Mar 14, 2019 18:14

Which 6.x.x Resolume version are your using exactly?
Theatre sound engineer, photographer, programmer, aka ravensc.
Control Your show with ”Enter” - multiple Resolume servers at once - SMPTE/MTC column launch
try for free: http://programs.palffyzoltan.hu
VJ footage: https://goo.gl/58oHy7

nuvedai
Met Resolume in a bar the other day
Posts: 4
Joined: Thu Mar 14, 2019 15:06

Re: OSC clip playback

Post by nuvedai » Thu Mar 14, 2019 18:28

6.0.7
Okay, I see something similar was addressed at 6.0.11
I'll update and see.
Thanks.

nuvedai
Met Resolume in a bar the other day
Posts: 4
Joined: Thu Mar 14, 2019 15:06

Re: OSC clip playback

Post by nuvedai » Thu Mar 14, 2019 19:01

Works! Sorry for unnecessary trouble / Thanks for showing the way

AndrewIAm
Met Resolume in a bar the other day
Posts: 1
Joined: Thu Oct 11, 2018 15:39

Re: OSC clip playback

Post by AndrewIAm » Mon Apr 08, 2019 16:53

nuvedai wrote:
Thu Mar 14, 2019 16:55
OSC play and pause (.../direction/2, .../direction/3) don't work
I am use 0 for Back, 0,33 for Fwd, 0,6 for Pause, 0,9 for Random. And its work

User avatar
HarryLoop
Met Resolume in a bar the other day
Posts: 4
Joined: Wed Apr 17, 2019 09:10
Location: Laputa

Re: OSC clip playback

Post by HarryLoop » Wed Apr 17, 2019 09:55

AndrewIAm wrote:
Mon Apr 08, 2019 16:53
nuvedai wrote:
Thu Mar 14, 2019 16:55
OSC play and pause (.../direction/2, .../direction/3) don't work
I am use 0 for Back, 0,33 for Fwd, 0,6 for Pause, 0,9 for Random. And its work
do you use 6.0.11 too? because after reinstalling does not work for me :?

Post Reply