Layers

Think of your composition as a painting, and you're creating 60 artworks per second. Every layer is a layer of paint on your canvas.

We start at the bottom, with a blank canvas. Layer 1 is the first layer of paint we put on. Then we add Layer 2, then Layer 3, slowly adding more and more layers on top of it, until we have a masterpiece. 

Or a great big mess. Sometimes both. It's your little world, and you can make it as happy as you want it.

Some people think that the first layer should be at the top. I guess that's because we're used to reading a book starting at the top left of the page (in a Western culture anyway). 

However, it's very rare to start a painting by applying the top layer first, and then gradually adding more paint underneath. Since we're artists painting a masterpiece, and not writers writing a novel, the first layer is the bottom layer.

Blending and Compositing

The first layer of paint is always applied on black. It will fill the entire canvas and you have full control over how thick you apply the paint. Simply grab the 'V' slider to fade the layer in and out.

Similarly, if you're playing audio, you can use the 'A' slider to fade the audio in and out. Or grab the 'M' slider to control both at the same time.

The fun really starts when you start blending layers together. Blending is like painting 'wet on wet'. The new layer of paint will blend with the paint that's already there. This way, every layer you add can be blended with the ones below it, in a variety of ways.

The default blend mode is 'Add'. Using Add, you simply add the new layer on top of the previous one, adding the pixels together. This is a great way to mix clips together that have a black background. 

Don't care about math? Feel free to skip ahead. Still here? Great. Black pixels have an RGB value of zero, and adding zero to something doesn't add anything. This is why black pixels become transparent when using the Add blending mode. Also, you're a nerd. Who likes math? Seriously.

Too Much of a Good Thing

Of course, you can have as many layers as you like. Or at least until smoke starts coming out of your computer.

New layers can be added with the Layer > New and Layer > Insert menu options. The New option adds the new layer to the top of the layer stack while the Insert options add the new layer above or below the currently selected layer. If you're a shortcut type of person, you can hit CTRL-L (or CMD-L on a Mac) to add a new layer as well.

This is a good moment to talk about composition, as in how you compose your overall visual output. 

It's very easy to keep stacking layer upon layer, but as the saying goes, less is often more. 3 layers can already be more than enough. A good composition gives each layer room to breath, instead of smearing every pixel shut.

The danger with Add blending is that, well, there's no other way to say it, it adds up.

 When using as little as 3 layers together, the result quickly becomes a white soup. Soup tastes great, but it's not very nice to look at. Also, when you're playing on a LED wall, the people in the front are now acutely aware of how silly they look and that that one boy they were flirting with is actually a speaker with a coat hanging from it.

Luckily, Resolume has many different ways to blend, including ways to make the output darker instead of brighter.

You change the blend mode by clicking on the dropdown marked Add, and choosing one from the big list. Let's go with Darken for the second layer, and Dodge for the third. 

There, much better. We can still see the texture and design of every layer, but the result is not so overwhelming.

Alpha Blending

By far the cleanest way to paint is to use content with an alpha channel. Clips with an alpha channel have transparency baked into them, so you can stack layers on top of each other, without mixing the paint. This way, you can precisely control which pixels to show and which ones to hide, while the overall composite stays crisp and clean.

Most of the content you purchase in the Resolume shop has an alpha channel. If your content doesn't, you can use the Auto Mask effect to turn the black pixels transparent. You will need to play around with the Contrast parameter to get the desired result.

A good way to approach a composition with alpha channels is to use a Background / Focus / Frame approach.

Your first layer will be your Background. You use this layer to paint the entire canvas with a screen filling loop. This gives your composition texture, and a base to start with. Abstract loops with some kind of pattern are great for this.

On top of this, you use the second layer to paint a more recognisable element. This is to grab the viewer's Focus. Faces are always a winner, but you can use anything that has some connection to the music or theme of the stage. If you're commercial oriented, this would be a great place for the DJ's logo.

The third layer will be used to Frame what's underneath. The layer will be used as a window, blocking some parts of the content underneath. Often used in movies, blocking the layers below gives a sense of depth to the overall composition, and constantly hiding and revealing parts of the composition keeps everything dynamic.

Of course, nothing is stopping you from using more layers, or even using multiple focus points on a more complex stage design.

Types of Blends

Unfortunately, this manual is not long enough to go into detail into what each blend mode does exactly. 

Blends

These will blend and mix the paint of your layers. At 50% opacity, they will fully mix the paint with the layers underneath. At 100% opacity, they will just fully cover the paint underneath, as if you're putting a completely new layer of paint on your canvas.

Some blends will create a brighter output, like 'Add', 'Lighten' and 'Screen'. Others will darken the output, like 'Subtract', 'Darken' and 'Multiply'. Some just do weird stuff like 'Difference I' or 'Dodge'.

It's best to just sit down, grab a cup of coffee or tea and try them all out. Get a general feel for what they do. Remember to try them with different types of content, as that can create very different results, depending on the blend.

50 Blends

These are special types of blends. They do the same as their regular counterpart, except that they mix their paints with the opacity at 100%. They're especially useful for doing AV mixing, because you can have both the audio and video sliders all the way up. Or if you like throwing your midi faders all the way open like a superstar DJ.

Transitions

Some blends are actually transitions. By fading the layer from 0% to 100%, some sort of transition is applied. 

For instance, 'MultiTask' will do a Cover Flow type of transition, where the new layer will come in from the side and push the layer below to the back. 'Shift RGB' will bring in the Red, Green and Blue channels of the new layer in from the left, right and top.

Transitions work best for presentation type of shows, but for instance 'to White' can work great to bring in a new layer with a bang during a VJ set.

Eject, Bypass and Solo

These three bad boys can be found on the far left of the layer strip.

The X will eject the currently playing clip from the layer.

The B will bypass or Blind the layer, temporarily hiding it from view.

The S will Solo the layer, hiding everything but the current layer. This is useful to quickly focus on a layer when troubleshooting, or as a visual effect during show to emphasise a certain element.

Be careful you don't end up in a BS situation, where you both Solo and Bypass a layer, because then you end up with a whole lot of nothing.

Layer Order

You can change the order of layers simply by dragging a layer by the name handle and dropping it where you want it. 

Layer Transition

Layer Transitions will let you add a transition when you trigger a new clip in a layer. This way you can smoothly blend from the old playing clip to the new one.

The auto layer transitions can be found by choosing View > Show Layer Transition Controls, and they will pop up to the left of the clip thumbnails.

Once visible, simply fade up the vertical slider to set a transition time between 0 and 10 seconds. If you like numbers as much as I do, you can also set the transition time precisely down to the millisecond in the Layer panel.

The transition mode will default to Alpha, which is a simple crossfade. If that's too basic for you, you can choose all of the available blends and transitions instead. 'Twitch' is one of my favourites. Also, 'Cube' is amazing just for sheer corniness.

If you really can't decide on a favourite transition, there is also a random option, giving you a different transition every time you trigger a new clip. 

Previous / Next Clip

Yes! These buttons will let you trigger the next or previous clip in that layer. Yes, you can also assign MIDI and keyboard shortcuts to these buttons.

These buttons come as a bonus with the Layer Transition Controls, and can be revealed via View > Show Layer Transition Controls.

Layer Properties

To select a layer, click the area that displays the layer's name, for example Layer 1. The currently selected layer is highlighted in blue.

Auto Pilot

This will let you play a sequence of clips in a layer. When the current clip has reached the end, Resolume will trigger the next, previous or a random clip automatically.

Tip! Clicking the Next, Previous or Random button before the current clip has reached the end will force the Auto Pilot to do its thing prematurely. Don't worry about it, triggering prematurely happens to everybody. You were probably just nervous.

The Auto Pilot can also be set on the Clip level. In that case, you have the extra option to target the first, the last or even a specific clip in the layer directly.

Common

This contains the Master fader for the layer. This fades both the playing audio and video at the same time, without affecting their individual levels.

Audio

This will let you control the Volume and Pan of the audio playing in the layer.

Video

Here you can choose the Blend Mode and Opacity of the layer. These controls are the same as can be found on the layer strip at the top.

Width & Height will let you change the resolution the layer renders at.

Tip! Lowering the Width & Height can save you considerable render power. For instance, you can render a 7680x4320 composition, with four layers each set to 3840x2160, positioned in the four corners. Each layer will only process at the resolution its set to, instead of processing at the full 8K resolution.

Auto Size is great to make sure your content always matches your layer size. You can set all content to automatically Fill, Fit or Stretch to the layer size.


  • Off will keep the content as it is.
  • Fill will make sure the content fills the entire layer, while maintaining its aspect ratio. This will result in the sides or the top and bottom of the clip being cropped off. 
  • Fit will make sure your content is completely visible, while maintaining its aspect ratio. This will result in black borders being visible on the sides or top and bottom.
  • Stretch stretches the clip to the layer width and height, distorting the content when necessary. 

Layer Transport Controls

The Layer Transport Controls give you quick access to the transport section of the clip currently playing in that layer.

These will let you quickly change the speed, direction and loop mode of the clip. Also you can grab the playhead and scratch it. When in BPM Sync mode, you will see the amount of beats instead of the speed.

Practically, these controls can also be found on the transport section on the clip tab, except you can see and control more than one clip at the same time. Changing anything in one place, will also update it in the other.

You can show and hide the Layer Transport Controls via View > Show Layer Transport Controls

Trigger Options

These will set particular trigger options for all clips in a layer. They can of course be overridden for individual clips on the clip level.

Ignore Column Trigger

With this enabled, any clips in this layer will keep on playing when a column is triggered. This is useful to keep clips like live inputs or background around, but change all the other content with a single click.

Trigger first clip on load

After the composition has finished loading, the first clip in the layer will be triggered automatically. After this, any Auto Pilot actions will be executed normally. You can use this to do basic installations with Resolume, or to quickly get a test card up and running when you launch the software.

Fader Start

This will retrigger the current clip, every time you bring the opacity up.

Mask Layer

A layer can be set to Mask Mode, masking either all the layers below, or just one layer.

In Mask Mode, the layer will use the black and white values of the content currently playing in the layer to show or hide the layer(s) below. Alpha will be treated as black.

To give a visual indication of what's going on, Resolume will show the thumbnails in greyscale. Also, it will show a little corner with a transparency checkerboard, as a visual reminder this layer is currently being used as a mask.

All Below will apply the mask to all the layers below the Mask Layer. It's essentially the same as setting the layer to Mask50. 

One Below will apply the mask to just the layer right underneath the Mask Layer, and leave the other layers unaffected. If you're familiar with After Effects, it's the same as setting a layer to Luma Track Matte.

Disabled will set the layer back to be a normal layer again.

Lock Content

This will let you lock the content currently playing in the layer.

All this does is make sure that you cannot accidentally eject the current clip or trigger a different clip into this layer. Both the layer and clip parameters can still be controlled and changed.

As a visual indication, a lock icon is displayed over the layer thumbnail.

Duplicate, Rename, Clear and Remove

Of course, you can Duplicate, Clear, Remove or Rename a layer as well. I think it's pretty obvious what Duplicate does.

Rename is kind of special. Obviously, you can use it to rename the layer. 

It's special because you can use # as a special character. When displaying the name, Resolume will replace the # character with the current position the layer has in the stack. So, for instance, naming the layer "L# Mask", will display the layer name as "L3 Mask", if it's the third layer in the stack. Moving the layer up or down will automatically update the displayed name.

The difference between Clear and Remove is that Clear just clears out all the content from a layer, but keeps the layer itself around. Remove will get rid of both the content and the layer in one fell swoop.

Related Articles